加入了代码高亮插件

  • 本站文章除注明转载外,均为本站原创或者翻译。
  • 本站文章欢迎各种形式的转载,但请18岁以上的转载者注明文章出处,尊重我的劳动,也尊重你的智商;
  • 本站部分原创和翻译文章提供markdown格式源码,欢迎使用文章源码进行转载;
  • 本博客采用 WPCMD 维护;
  • 本文标题:加入了代码高亮插件
  • 本文链接:http://zengrong.net/post/90.htm

为Blog安装了andotCoolCode插件。但是由于我写的大多数都是ActionScript代码,但是这个插件中偏偏又没有ActionScript高亮支持的文件,无奈只有自己做一个了。

目前的文件包括Flash 8 ActionScript和Flash Communicotion Server的绝大部分关键字、方法、构造器和对象,但不包含对组件方法的支持。

和我有同样需求的朋友可以这样做:

1. 首先在WordPress中安装CoolCode
2. 下载后面的文件:

  用于CoolCode插件的ActionScript语法高亮文件 (9.2 KiB, 1,288 hits)

3. 将其解压缩后复制到如下文件夹中(视具体安装路径而定);

/wordpress/wp-content/plugins/coolcode/PEAR/Text/Highlighter/

4. 打开coolcode.php,搜索下面的语句:

var $acceptable_lang = array('php', 'cpp', 'css', 'diff', 'dtd', 'javascript', 'html', 'mysql', 'perl', 'python', 'ruby', 'sql', 'xml', 'java');

将“actionscript”支持加入其中:

var $acceptable_lang = array('php', 'cpp', 'css', 'diff', 'dtd', 'javascript', 'actionscript', 'html', 'mysql', 'perl', 'python', 'ruby', 'sql', 'xml', 'java');

想偷懒的朋友可以直接下载已经修改好的

  coolcode.php (3.4 KiB, 1,293 hits)

5. 修改完毕。效果可以看 这里

另:

如果要自行编辑高亮语法文件,可以参考 这里