不重新编译,让官方网站下载的Vim支持Python

  • 本站文章除注明转载外,均为本站原创或者翻译。
  • 本站文章欢迎各种形式的转载,但请18岁以上的转载者注明文章出处,尊重我的劳动,也尊重你的智商;
  • 本站部分原创和翻译文章提供markdown格式源码,欢迎使用文章源码进行转载;
  • 本博客采用 WPCMD 维护;
  • 本文标题:不重新编译,让官方网站下载的Vim支持Python
  • 本文链接:http://zengrong.net/post/1690.htm


在为Vim安装VimPress插件的时候,发现它需要Python支持。查了一些资料,原来在编译Vim的时候,是可以将Python语言整个编译进入Vim中的。这样的Vim可以直接使用Python语言来写扩展。

除了编译嵌入方式,在Windows系统中,Vim还可以以动态链接的方式支持Python。

Vim的帮助文件中这样描述:

Vim 可以用四种方式编译 (:version 输出结果):
1. 无 Python 支持 (-python、-python3)
2. 只有 Python 2 支持 (+python 或 +python/dyn、-python3)
3. 只有 Python 3 支持 (-python、+python3 或 +python3/dyn)
4. Python 2 和 3 支持 (+python/dyn、+python3/dyn)

我的Vim是在Vim官方网站下载的32位windows版。怎么知道我的Vim有没有包含Python支持呢?

使用:version命令可以查看Vim编译时候的选项,看看输出的信息中是否包含上面帮助中描述的选项,就能知道自己使用的Vim对Python的支持情况。

在Vim官方网站下载的32位Vim 7.3.46版,是带有+python/dyn和+python3/dyn选项的。所以我们只需要再安装Python环境就行了。

安装的过程也很纠结,许多地方需要注意。我辗转Stack Overflow和Google数次才搞定。下面是具体的过程。

我的计算机环境:

  • Window 7 64bit
  • Vim 7.3.46 32bit
  1. 访问下载Pyton安装包,使用Python2还是Python3取决于你自己。
    但要注意,一定要下载和自己Vim匹配的版本。例如我的Windows虽然是64bit,但是由于Vim是32bit,这里就必须下载32bit的Python安装包。
    Python官方网站非常贴心的为天朝用户准备了一个“下载”链接。你一定要点击那个链接下载。否则,你会被GFW干掉。
  2. 安装过程没有什么好说。我选择的路径是d:\Python2.7
  3. 设置环境变量中的PATH变量,将你的Python安装路径加到PATH末尾。
    我永久性鄙视Windows的环境变量配置界面,都多少年了,还搞那么个小框,居然还不能拉大!
  4. 重启电脑。重启的原因是我们需要让新的环境变量生效。虽然有很多非官方的方法可以让环境变量的改变立即生效,但某些时候貌似不靠谱。我再次永久性鄙视微软。
  5. 进入Vim界面,输入echo has("python"),如果输出1,代表你的配置成功了。

如果配置没有成功,仔细检查以下几条:

  1. 你的Vim是否是在官方网站下载的Vim 32bit版本?
  2. 你的Vim编译信息中是否包含+python/dyn或者+python3/dyn?检验方法见上文。
  3. 你下载的Python版本是否和Vim版本不匹配?他们必须同时是32bit或者64bit版才行。
  4. 你是否正确设置了环境变量?可以使用win+r然后输入python回车试试。如果能显示python提示符,说明你的设置正确。
  5. 设置了环境变量后,是否重启了计算机?

如果试了所有的办法均不奏效,那就重新编译一个支持Python的Vim吧!

祝你成功!