【译】使用Yum在CentOS上安装Ruby 1.8.6

  • 本站文章除注明转载外,均为本站原创或者翻译。
  • 本站文章欢迎各种形式的转载,但请18岁以上的转载者注明文章出处,尊重我的劳动,也尊重你的智商;
  • 本站部分原创和翻译文章提供markdown格式源码,欢迎使用文章源码进行转载;
  • 本博客采用 WPCMD 维护;
  • 本文标题:【译】使用Yum在CentOS上安装Ruby 1.8.6
  • 本文链接:http://zengrong.net/post/1673.htm

2012-10-31更新:修改源地址,以前的源地址已经不能使用。


原文:Installing Ruby 1.8.6 on CentOS with Yum

64位系统:

$ sudo rpm -Uvh http://dl.fedoraproject.org/pub/epel/5/x86_64/epel-release-5-4.noarch.rpm
$ sudo rpm -Uvh http://download.elff.bravenet.com/5/x86_64/elff-release-5-3.noarch.rpm
$ sudo yum install ruby ruby-shadow ruby-ri ruby-rdoc gcc gcc-c++ ruby-devel -y
$ ruby -v
ruby 1.8.6 (2010-02-05 patchlevel 399) [x86_64-linux]

32位系统:

$ sudo rpm -Uvh  http://dl.fedoraproject.org/pub/epel/5/i386/epel-release-5-4.noarch.rpm
$ sudo rpm -Uvh http://download.elff.bravenet.com/5/i386/elff-release-5-3.noarch.rpm
$ sudo yum install ruby ruby-shadow ruby-ri ruby-rdoc gcc gcc-c++ ruby-devel -y
$ ruby -v

安装RubyGems:

$ wget http://rubyforge.org/frs/?group_id=126&release_id=43601
$ tar xzvf rubygems-1.3.7.tgz 
$ cd cd rubygems-1.3.7
$ sudo  ruby setup.rb 
$ gem --version
1.3.7